Results 1 to 2 of 2

Thread: Reflection bug?

Hybrid View

  1. #1
    Join Date
    May 2009
    Posts
    5

    Default Reflection bug?

    Try this in a new scene and do a region render:

    Code:
    CreatePrim("Sphere", "MeshSurface", null, null);
    SetValue("sphere.sphere.radius", 2, null);
    SetValue("sphere.polymsh.geom.subdivu", 6, null);
    SetValue("sphere.polymsh.geom.subdivv", 6, null);
    ApplyShader("$XSI_DSPRESETS\\Shaders\\Material\\Lambert.Preset", "", null, "", siLetLocalMaterialsOverlap);
    SetValue("sphere.Material.Lambert.diffuse.red", 0, null);
    SetValue("sphere.Material.Lambert.diffuse.green", 0, null);
    SetValue("sphere.Material.Lambert.diffuse.red", 0, null);
    SetValue("sphere.Material.Lambert.diffuse.green", 0, null);
    SetValue("sphere.Material.Lambert.diffuse.blue", 0, null);
    SetValue("sphere.Material.Lambert.reflectivity.red", 0.854, null);
    SetValue("sphere.Material.Lambert.reflectivity.green", 0.854, null);
    SetValue("sphere.Material.Lambert.reflectivity.blue", 0.854, null);
    CreatePrim("Grid", "MeshSurface", null, null);
    SetValue("grid.grid.ulength", 32, null);
    SetValue("grid.grid.vlength", 32, null);
    Translate(null, 0, -2, 0, siRelative, siLocal, siObj, siXYZ, null, null, null, null, null, null, null, null, null, 0, null);
    ActivateObjectSelTool(null);
    This is what I get:

    The top render is how it looks if I do a region render straight away.
    The lower render is how it looks if I set Visible Geometry Side to Front in the Renderer Options.

    Whats going on? Is this a genuine bug?



    The renders were done in 7.5 demo.

  2. #2
    Join Date
    Aug 2007
    Location
    East Coast
    Posts
    1

    Smile

    You may want to check your options for the render region,

    Region>All Options.

    Check your raytracing depths and geometry options.
    Render Theory: It either renders or it doesn't.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •